腾讯蓝鲸论坛-专业的技术交流论坛

 找回密码
 立即注册
忘了密码?
搜索
热搜: 用户手册 FAQ
查看: 561|回复: 1

[建议反馈] winagent支持的python脚本版本太低,插件太少

[复制链接]

1

主题

0

好友

13

积分

预备会员

Rank: 1

发表于 2017-6-19 16:03:11 |显示全部楼层
首先,应该非常感谢蓝鲸团队的辛勤劳作给我们带来这么好的运维工具
为不浪费大家时间,不罗嗦,直入主题了。

作业平台执行脚本用的是winagent中cygwin集成的脚本语言,其中python默认版本是2.5.5,有以下问题:
1.比起我们平常用的2.7.2都低,使得我们调试好脚本之后需要重新再调试一遍,或直接把开发环境降低到2.5.5.
2.cygwin本身就存在插件不齐且安装不便,再加上官方的cygwin版本也较老,用的包是bz结尾的;而当前镜像啥的都是用xz结尾的文件,双方不能互相识别;直接用官方的cygwin也无法通过直连获取新的安装包。

1

主题

0

好友

13

积分

预备会员

Rank: 1

发表于 2017-6-19 16:05:17 |显示全部楼层
建议蓝鲸团队统一更新下官方的一键安装的下的cygwin版本,让其能与当前镜像包接洽,以便脚本开发人员可以快速的根据需求下载自己所要的插件包。
您需要登录后才可以回帖 登录 | 立即注册

蓝鲸官网

GMT+8, 2018-1-20 17:17

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部